Copyright © 2002-2012, Agent Oriented Software Pty. Ltd.

JACK Intelligent Agents® Design Tool Manual

Release 5.5
2 September 2010


Table of Contents

Publisher Information

 Agent Oriented Software Pty. Ltd.  
 P.O. Box 639,  
 Carlton South, Victoria, 3053  
 AUSTRALIA  
   
Phone: +61 3 9349 5055
Fax: +61 3 9349 5088
Web:  http://www.agent-software.com

If you find any errors in this document or would like to suggest improvements, please let us know.

The JACK™ documentation set includes the following manuals and practicals:

Document Description
Agent Manual Describes the JACK programming language and infrastructure. JACK can be used to develop applications involving BDI agents.
Teams Manual Describes the JACK Teams programming language extensions. JACK Teams can be used to develop applications that involve coordinated activity among teams of agents.
Development Environment Manual Describes how to use the JACK Development Environment (JDE). The JDE is a graphical development environment that can be used to develop JACK agent and team-based applications.
JACOB Manual Describes how to use JACOB. JACOB is an object modelling language that can be used for inter-process transport and object initialisation.
WebBot Manual Describes how to use the JACK WebBot to develop JACK enabled web applications.
Design Tool Manual Describes how to use the Design Tool to design and build an application within the JACK Development Environment.
Graphical Plan Editor Manual Describes how to use the Graphical Plan Editor to develop graphical plans within the JACK Development Environment.
JACK Sim Manual Describes how to use the JACK Sim framework for building and running repeatable agent simulations.
Tracing and Logging Manual Describes the tracing and logging tools available with JACK.
Agent Practicals A set of practicals designed to introduce the basic concepts involved in JACK programming.
Teams Practicals A set of practicals designed to introduce the basic concepts involved in Teams programming.


1 Introduction

The JACK Design Tool™ (Design Tool) enables design and planning of JACK™ (JACK) applications to occur within a convenient, icon-based environment. By providing a visual representation of the various links between components in any given design, a clear representation of the overall design structure can be obtained.

The Design Tool is a graphical mechanism used to design agent and teams systems, while simultaneously populating the JACK Development Environment (JDE) project directory with design skeletons that can be built upon and developed further at any given point in time.

Design elements (such as agents, events and plans) can be dragged from the JDE browser window or the palette to the canvas, at which point any links can be made that declare relationships between the design elements.

At all times the link between structural elements on the canvas and in the browser is consistent, and the two representations are continually and automatically updated.

Changes on the canvas are visible immediately in the JDE browser. Changes are highlighted in red in the JDE browser until saved, at which point their text turns to black. Likewise, changes in the JDE browser are immediately represented on the canvas.

The Design Tool can be used in either Agent mode or Teams mode.

There are several advantages of using the Design Tool. Benefits include the ease with which the user can build and develop designs with familiar 'drag-and-drop' and mouse-controlled design techniques.

The Design Tool also reduces the difficulty of visualising and understanding the often complex nature of agent and teams design.

Graphical representation of a design, such as that provided by the Design Tool, offers the following benefits:

1.1 Design Tool fundamentals

The JDE is a graphical environment for the development, execution and maintenance of JACK software. It provides the user with access to a number of tools which facilitate the process, namely:

The focus of this manual is the Design Tool; the reader is referred to the Development Environment Manual and other specific manuals for details about JACK tools.

Access to the Design Tool is normally via the JDE browser. A project is first opened or created within the JDE (refer to the Development Environment Manual for details). This creates a JDE browser window within the JDE window. The user can then create new designs or access existing designs from the Design Views folder in the JDE browser.

The purpose of the Design Tool is to enable designs to be created, modified, viewed and deleted using an intuitive graphical user interface (GUI). To use the Design Tool effectively, the user must be familiar with both the structure of a design and the structure of the Design Tool.

1.2 Design Tool within the context of the JDE

The Design Tool is accessed through the Design Views folder, located in the JDE project window. It is useful to be familiar with the JDE in order to use the Design Tool effectively. For further information on the JDE, refer to other sections within the Development Environment Manual.

Figure 1-1: Project window (left), tool bar (top right) and canvas (bottom right)

The JDE project window consists of the Design Views folder, the Agent Model, the Data Model, and the Other Files folder. The Design Views folder contains all of the design views that belong to a project.

Expanding the Design Views folder, by double-clicking on the Design Views folder icon or label, results in the individual design views stored within becoming visible.

To open a design view stored within the Design Views folder, double-click on either the Design Views label or its associated icon. A canvas will appear in the JDE browser. The design view can then be modified as required.

Figure 1-2: Tool bar and canvas of a stored design

1.3 General Design Tool features

Tool features used extensively throughout the Design Tool include the following:

Figure 1-3: Moving the mouse pointer over a button elicits tool tips

1.4 Operating system notes

The screen snapshots in this manual were created on a Macintosh running Apple's Mac OS X operating system. On another platform, the Design Tool will look slightly different, but these differences are only cosmetic, and will not affect the performance of the Design Tool in any way. In some cases, menu options may be found in different locations.

There are also some differences in operating system-specific conventions regarding mouse buttons and modifier keys. These are listed and explained below.

1.4.1 Mouse buttons

Unix systems typically have a three button mouse, Windows systems have a two button mouse, and Macintosh systems have a single button mouse.

In the JDE and Design Tool, the left and right mouse buttons function in the same way on Unix and Windows systems. The middle button is unassigned, and not used for any purpose.

To access the functions of the right mouse button on a Macintosh system, hold down the CTRL key while pressing the mouse button (unless a third-party two button mouse is available allowing the use of the right button as required).

1.4.2 Modifier keys

Generally, where a CTRL key is used in Windows and Unix, the COMMAND key is used on the Macintosh. For example, on Windows you use the CTRL key to make multiple selections. On the Macintosh you would use the COMMAND key. The SHIFT key performs the same function on all three platforms.


2 Design structure

A design consists of components such as agents, teams, events and capabilities. Components can be dragged and dropped from the Agent or Teams mode Design Palette onto the canvas, and moved into position. From this point, links (relationships) between components can be created as a design is assembled.

There are two main types of components: agent components and teams components. The components of an agent design are: agent, capability, event, plan and beliefset. The components of a teams design comprise the components of an agent design, plus the three components specific to teams design, namely: team, role and teamplan.

Commonly used design diagrams can illustrate:

  1. The events passed between agents
  2. agent and capability hierarchies, and
  3. data/event/dependency diagrams.


Note: The Design Tool enables a designer to create design models according to the designer's adopted methodology. It allows the designer to create design diagrams as required.

2.1 Agent mode components

Components available on the Design Palette in Agent mode are the five standard agent components: Agent, Event, Capability, Plan and Beliefset. A Note option is also available, with which the user can make brief notes that can be attached to any selected component.

Agent mode is the default; the Design Tool automatically opens into Agent mode when the JDE is opened for the first time. However, should a project be saved and closed while in Teams mode, the Design Tool will keep the Teams mode setting. The next time that the Design Tool is opened, it will open in Teams mode. The Design Tool is also capable of detecting whether an imported design is an Agent or Teams design, and of opening in the appropriate mode.

Where Agent mode provides the ability to design systems with agent features, Teams mode provides the option of designing systems with teams features.

2.2 Teams mode components

The drop-down View menu provides the Teams mode option for the JDE. Clicking on the Teams mode option toggles the JDE between Agent mode and Teams mode.

Teams mode can also be toggled with the Teams Mode On/Off button on the JDE tool bar.

Components available to the user when the Design Palette is in Teams mode are Team, Role and Team Plan, as well as the five agent components and the Note option.

2.3 Links

Links are the relationships between components. It is the links between components that transform a collection of components on the canvas into a design. A link is represented by a line arrow between two components, and can be edited by double-clicking on the link when in Selection mode.

Figure 2-1: A link which represents that the agent type can post an event of type 'event'

2.3.1 Link points

Link points are the enlarged points around the perimeter of a component which appear when the mouse pointer moves over a component while the Design Tool is in Link mode. Links connect components by their link points.

Figure 2-2: Link points visible on a plan

Link mode is discussed later in this document.

2.3.2 Link types

Two types of links exist between components:

2.4 Design views within a project

A JDE project can have multiple design diagrams. A large and complex design is better served broken up into smaller design elements, with each design diagram showing certain aspects of the overall design. Each design diagram is shown in a separate window, allowing multiple diagrams to be compared and discussed simultaneously.


3 Design Tool structure

The following is a list of specific structural elements available within the Design Tool.

3.1 Control bar

At the top of the Design Tool window is the control bar. On the control bar, from left to right, are the Documentation checkbox, the Design Graph checkbox, the Export design diagrams button and the Print design diagrams button.

Figure 3-1: Control bar

3.1.1 Documentation checkbox

The Documentation checkbox opens a Documentation textbox in which more detailed comments about the diagram can be entered and stored. When the Documentation checkbox is checked, documentation relevant to each diagram is immediately visible without intruding pop-ups, or the user needing to change windows. Unchecking the checkbox removes the Documentation textbox from view.

Documentation can be saved or updated by saving the associated project. To make the Documentation textbox disappear, simply uncheck the Documentation checkbox above the tool bar.

3.1.2 Design Graph checkbox

Ticking the Design Graph checkbox opens the canvas design. The Design Graph checkbox provides a means by which a diagram can be closed from view while documentation is being added in the Documentation textbox (opened, as explained above, by clicking the Documentation checkbox).

3.1.3 Export design diagrams

Clicking on the Export design diagrams button on the tool bar exports any design in the current project. When the Export design diagrams button is clicked, an Export Design Diagrams window pops up, enabling the user to select which designs and which attributes of the designs will be exported.

Within the Export Design Diagrams pop-up dialog box, there are options for exporting the following design diagram features:

The dialog box also contains text fields for entering the width and height of the exported design.

Figure 3-2: Exporting Design Diagrams window

3.1.4 Print design diagrams

Clicking on the Print design diagrams button on the tool bar prints any design. When the button is clicked, a Print Design Diagrams window pops up, enabling the user to select which, and how many, designs to print.

It is important to note that any or all designs can be selected for printing in the same print run via the selection options on the right of the pop-up options window.

Within the Print Design Diagrams pop-up dialog box, there are options for printing the following design diagram features:

Figure 3-3: Printing Design Diagrams window

3.2 Tool bar

Directly beneath the control bar is the tool bar. On the tool bar are several buttons providing various functions, plus the zoom slider. It is with these functions that the Design Tool is used, and designs are created and modified.

The tool bar can be considered the 'control centre' of the Design Tool. The functions available on the tool bar, from left to right, are:

Figure 3-4: Tool bar

3.2.1 Selection mode

Selection mode is one of two modes in which the user can edit designs.

To enter Selection mode, click on the Selection mode button on the tool bar. The Design Tool is in Selection mode when the Selection mode button is indented.

Selection mode enables the user to move components around on the canvas, and to highlight design components for editing or deletion. Clicking on design elements highlights them in blue. Any changes in the canvas result in the JDE browser being automatically updated and highlighted in red text.

3.2.2 Link mode

Link mode is one of two modes in which the user can edit designs.

To enter Link mode, click on the Link mode button on the tool bar. The Design Tool is in Link mode when the Link mode button is indented.

While in Link mode, links between the various components in a given design can be created, edited and deleted. Changes will be highlighted in the JDE browser. Changes do not revert to the default black text colour in the JDE browser until they have been saved or discarded.

Moving the mouse over a component in the canvas while in Link mode will cause the selected component to be highlighted in red. A series of link points on the perimeter of the component will become visible. Fixed links are made to and from these points, and floating links can be created from anywhere within a component.

3.2.3 Remove selected objects

The Remove selected objects from diagram button (Remove button) can be used to either remove a component (e.g. an agent, event etc.) from a design, or remove the link between two components. To remove a component or link, left-click on the selected design element on the canvas while in Selection mode. The Remove button will become enabled, and the component or link to be deleted will become highlighted.

Once the component to be deleted is highlighted, click on the Remove button. The selected component or link will be deleted from the design. In the case of links, a prompt will appear asking the user to confirm that they wish to remove the link. This is because removing a link from a design also deletes the link from the underlying model. No such prompt appears when deleting a component, as the component is only deleted from the design, not from the underlying model.

3.2.4 Open design palette

The Open Design Palette button opens a palette from which a selection of components can be dragged onto the canvas. Links between components can then be created and edited, as the design is assembled.

If the palette is opened while the Design Tool is in Agent mode, the Design Palette will be opened in Agent mode. However, if the Design Tool is in Teams mode , the Design Palette palette will be opened in Teams mode.

The palettes provide access to the component types that make up a design. They provide a base from which components can be dragged and dropped onto the canvas.

The palettes are accessed via the tool bar. They are opened by left-clicking on the Open Design Palette button. The components available on the Design Palette can then be dragged and dropped onto the canvas using the mouse.

New components can be added to a design on the canvas with the palette. However, to link existing components in the design diagram, previously created entities can be dragged from the JDE browser on to the canvas.

The Design Palette can also be accessed via the JDE menu bar at the top of the JDE window. To access the palettes in this manner, click on the Window menu, then click the Design Palette option.

3.2.5 Design Palette – Agent mode

When in Agent mode, the Design Palette provides the five standard components of agent design, plus the Note option. The five standard components of agent design are Agent, Capability, Event, Plan and Beliefset.

Figure 3-5: Design Palette in Agent mode

3.2.6 Design Palette – Teams mode

When in Teams mode, the Design Palette is accessed by selecting the Design Palette option from the Window menu.

Figure 3-6: Design Palette in Teams mode

When in Teams mode, the Design Palette provides Teams mode components that can be dragged and dropped from the Design Palette onto the canvas.

3.2.7 Zoom slider

The zoom slider enables the user to increase or decrease the size of the design display within the Design Tool window. Various parts of a design can be focused upon using a combination of the zoom slider and the scroll bars to the right side and at the base of the canvas.

Figure 3-7: Zoom slider

3.2.8 Filter components shown

The Filter components shown option enables the user to hide various components in any given design, providing a clearer view of the relationships between elements.

Boxes that are checked in the filter components option window relate to components that are visible in the relevant design. To filter a component, rendering it invisible, simply uncheck the relevant checkbox.

When a component is filtered from a design, the links relating it to other components within that same design are also filtered, as are any indirect links to that component.

Components are filtered according to their type. For example, event components can be filtered out by ensuring that the Event Types checkbox is unchecked. Note that more than one type of component can be filtered out simultaneously.

Figure 3-8: Filter Components dialog (Teams mode)

Clicking the Filter components shown checkbox opens a dialog for a series of filter options. The user can choose to filter various component forms from the current design by clicking the relevant checkboxes associated with each component type.

3.2.9 Show indirect links

The Show indirect links option enables the user to see more clearly the relationship between components that are indirectly, rather than directly, linked.

Figure 3-9: Indirect Links options

When the Show indirect links button is pressed, a pop-up options window will appear. It provides a checkbox option to show indirect links, and a textbox to enter the number of filtered nodes between links. By altering the number of filtered nodes between indirect links, relationships of different proximity levels can be shown as required.

The Show indirect links function provides a means by which the user can clarify the relationship between components that are not directly linked, yet still share a relationship. A dotted link line appears on-screen, providing a means by which the relationship between indirectly linked components can be more readily identified.

The Show indirect links option is useful when used in combination with the Filter components shown option. Together they provide a powerful means of isolating and recognising indirect relationships within the overall context of any given design.

3.2.10 Using the indirect links function

To use the indirect links option:

  1. Click on the Show indirect links button. An Indirect Links pop-up window will appear.
  2. Check the Show indirect links checkbox in the pop-up window, and specify the indirect link order in the Indirect link order box. The Indirect link order box allows the user to specify the number of hidden nodes between the indirect nodes that will remain in view.
  3. Click the Apply Changes button at the base of the pop-up window.

The next step in hiding indirect links is to filter the component types that the user does not wish to view. To filter the components that will become hidden:

  1. Click on the Filter components shown button. A Filter Components pop-up window will appear.
  2. Click on the checkboxes of the components that require filtering. For example, if a plan requires filtering, click on the Plan Types checkbox.
  3. Click the Apply Changes button at the base of the pop-up window. The checked components will be filtered, and a dotted line linking the visible nodes at either end of the indirect link will have replaced the original (visible) indirect link.


Note: Using the indirect links option does not alter the design; it simply provides another way in which the design can be viewed.

Figure 3-10: Direct (left) and indirect (right) links

3.2.11 Descriptive mode

Descriptive mode enables the user to view documentation that is associated with any element on-screen within the context of a design.

The user can toggle between non-Descriptive mode (the default) and Descriptive mode by clicking on the Descriptive mode button in the Design Tool tool bar.

If an element does not have documentation associated with it, Descriptive mode will behave the same as non-Descriptive mode for that element. As in the non-Descriptive mode, only the name of the element will be shown.

3.3 Canvas

The canvas provides a working area in which graphical representation of the different design structure components can be created, modified, moved around and deleted.

Figure 3-11: Design Tool canvas

Links between the individual components can be built and modified on the canvas. These are graphically represented by line arrows between the different components. Links between components are created on the canvas.


4 Managing designs

This section contains instructions for creating, opening, importing, editing and saving designs. See the Development Environment Manual for instructions on:

4.1 Creating a design

A design will typically consist of many design diagrams, all of which illustrate different perspectives. In this way, a project is built systematically and different perspectives of the total design can be isolated.

Design diagrams are stored in the Design Views folder and its sub-folders. Sub-folders can be added to the Design Views folder by right-clicking on the folder and selecting the Add Nested Container option. It is also possible to change the name of the folder by selecting the Edit Label option from this menu. The other options in the Design Views folder menu are discussed in the following sections which illustrate how to create a design using the Design Tool.

4.1.1 Adding a new design view

Creating, editing and deleting components can be done at any stage of the design development process. Documentation can also be added, edited or deleted at any point during the creation of a design. The Design Views folder can be found near the top of the JDE project window.

To add a new design view:

  1. Right-click on the Design Views folder.
  2. A pop-up menu will appear, providing the options Edit Label, Add New Design View, Import Design View and Add Nested Container.
  3. Using either the left or right mouse button, click on Add New Design View. A dialog box will appear, in which to insert details of the new design view.

Figure 4-1: Add new design view

4.2 Opening a design

To open an existing design:

  1. Open the Design Views folder in the JDE browser. The existing design views will be visible within the Design Views folder.
  2. Right-click on the design to be opened, and select the Edit option from the pop-up menu.

4.3 Importing a design

The Import Design View option enables the user to import a design view that exists in another project. In other words, it enables the user to reuse a single design view within the context of one or more projects.

To import an existing design view using the Import Design View option:

  1. Using the mouse, right-click on the Design Views folder.
  2. A pop-up menu will appear, with the options Edit Label, Add New Design View, Import Design View and Add Nested Container.
  3. Click on Import Design View with either the left or right mouse button.
  4. The standard operating system dialog box will appear. The user can now navigate through their home directories until the relevant design is found.
  5. Click Import to load the design, or Cancel to cancel the operation.

4.4 Editing a design

To edit an existing design view:

  1. If not already open, follow the directions (detailed above) for opening an existing design view.
  2. Edit as required, by adding, editing and deleting new elements.
  3. Click the Save Project option, located on the drop-down File menu at the top of the JDE window.

4.5 Saving design changes

Changes to a design are saved when a project is saved in the JDE. See the Development Environment Manual for further information.


5 Preferences

Design Tool and Font preferences are accessed by selecting the Preferences option in the JDE Tools menu.

5.1 Design tool preferences

The Preferences window in the JDE has a Design Tool tab. This allows the user to alter the Preferences associated with the Design Tool.

To select an option, simply click on the textbox associated with the desired option. The options available within the Design Tool tab are as follows:

When this option is checked, the design bar is visible on all design windows within the Design Tool, enabling all tool bar functionalities to be within easy reach of the user. However, if this option is selected it will not apply to designs that are already open.

When this option is checked, the name labels on each of the icons on the design bar and palette are visible. However, this does not apply to designs that are currently open.

This option will enable a pop-up window confirming the user's wish to delete links in a design before the deletion command is carried out.

This option enables the tick marks on the zoom slider to be viewed. However, depending upon the degree of magnification of a given design, tick marks may not be helpful, and can be removed from view with this option to provide a cleaner view.

This option is not applied to designs that are already open in the JDE.

The zoom slider can be made visible, or can be hidden from view by toggling this option on or off. This option is not applied to designs that are already open in the JDE.

This option displays a drop down list of magnification percentage options to the left of the Descriptive mode button in the tool palette. It should be noted that when this option is selected it is not applied to Design Tool windows that are already open.

When this option is checked, the design tool will always open with the design initially in Descriptive mode.

This option creates Selection mode as a default rather than as a option of equal value with Link mode, so that after drawing a link the Design Tool returns to Selection mode, ready to enable the next link to be selected.

When selected this option enables the user to use a text editor(default or external) to edit the text in note nodes rather than a simple node editing dialog window.

This option displays the first sentence of non-note node documentation within a node when descriptive mode is on.

This option ensures that when descriptive mode is on that the node is resized and node text is reformatted to display all node documentation (or the first sentence if the previous option is selected).

This option enables the user to set the number of characters shown in a node when descriptive mode is used.

5.2 Font preferences

The Preferences option in the Tools menu of the JDE has a Fonts tab with the options listed below. Two options are given in this tab to change the font of node and link text in design diagrams. Note that when the options are changed and applied, Design Tool windows that are already open will need to be closed and then reopened for the changes to take effect.

Each preference has an Edit button, which opens a Font Chooser window. The Font Chooser window contains a list of fonts available on system being used, and from this list the Family, Typeface and Size of the font can be chosen.

The two options relevant to design diagrams are:


6 Design Objects

6.1 Components

In any given project, components can be loaded, created, modified and deleted. The way in which components are manipulated is a key factor in determining the layout of any given design.

6.1.1 Context menus

When the Design Tool is in Selection mode, right clicking on a component opens a context menu with options for editing or removing the component.

The context menu options available for nodes are:

6.1.2 Importing existing components

Components that have already been created can be dragged from the JDE browser and dropped onto the canvas, rather than being recreated with the palette.

6.1.3 Creating new components

To create a new component and define its relationship to the rest of a design, click on the palette button on the tool bar (or type SHIFT-CTRL-D). This will open the palette, with a selection of component types (Agent, Capability, Event etc.). Drag the required component on to the work area. As the component is being dragged, it will remain blue.

Once the component is dropped onto the Design Tool canvas by releasing the left mouse button, a dialog box will pop up. The component can now be named, its package can be defined, and any relevant documentation can be added. The component will also be added to the browser window.

6.1.4 Editing components

To edit the attributes of a component in the Design Tool, double-click with the left mouse button (or use the Edit... option of the context menu) on the relevant component. A dialog box will open that enables the name, package and documentation of the component to be edited.

Internal details of a component are edited in the JDE browser or by editing the component as a JACK file.

6.1.5 Editing components between design views

Editing a component in one view results in those changes being carried over into all views. For example, should a component be renamed in one view, all references to that component will be renamed. Any links that are removed will result in the appropriate changes being made within the JDE browser and to any relevant design views.

6.1.6 Removing components from a diagram

To remove a component from a design view:

  1. Ensure that the Design Tool is in Selection mode. If the Design Tool is in Selection mode, the Selection mode button will be indented. If not, and the Link mode button is indented, click on the Selection mode button to switch to Selection mode.
  2. Using either the left or right mouse button, click on the component to be removed. The component will become highlighted in blue.
  3. Click on the Remove selected objects from diagram button on the tool bar at the top of the Design Tool.
  4. The selected component and its associated links will be removed from the design view.

Alternatively, when in Selection mode use the Remove from Diagram context menu option.


Note: The component and its associated links have been deleted from the design view – they still exist in the project.

6.1.7 Removing components from a project

To remove a component from a project:

  1. Ensure that the Design Tool is in Selection mode. If the Design Tool is in Selection mode, the Selection mode button will be indented. If not, and the Link mode button is indented, click on the Selection mode button to switch to Selection mode.
  2. Right click on the component to open the context menu.
  3. Select the Remove from Project option. A Delete File and References dialog will open, with Delete and Cancel buttons. Click on the Delete button.
  4. The selected component and its associated links will be removed from the project.

6.2 Links

Links define the relationships between the different components in a design.

6.2.1 Context menus

Right clicking on a link opens a context menu with options for editing or removing the link.

The context menu options available for links are:

6.2.2 Creating links

To create a link between two components:

  1. Ensure that Link mode is switched on. Link mode is on when the Link mode button is indented.
  2. Move the mouse cursor over the component from which the new link originates. A series of link points (enlargements) will appear around the perimeter of the selected component. The component will also become highlighted in red.
  3. Select a conveniently positioned link point.
  4. Click and hold the left mouse button over the selected link point. Drag the mouse cursor toward the destination component.
  5. As the mouse cursor reaches the destination component, the destination component will become highlighted in red with a series of link points. Move the cursor to a conveniently positioned link point.
  6. Release the mouse button. A pop-up menu will appear over the Design Tool, confirming the nature of the relationship between the two components.

If the user has made an error in establishing the nature of the link between the two components, the link flow direction can be reversed by double-clicking on the link while in Link mode. A pop-up box will appear, and the link can be edited as required. Alternatively, the incorrect link can be deleted using the Remove selected objects from diagram button. A new correct link can then be created in its place.


Note: In all link instances, the direction of the link arrow is important, as it establishes the relationship between the two components.

6.2.3 Editing links

To edit a link between two components:

  1. Ensure that the Design Tool is in Selection mode. Selection mode is switched on when the Selection mode button is indented.
  2. Double-click with the left mouse button on the link that requires changing.
  3. Edit the link as required.

To edit the attributes of a link between two components in the Design Tool, double-click with the left mouse button (or use the Edit Link... option of the context menu) on the relevant link. A dialog box will open that enables the reference label of the link to be changed.

6.2.4 Removing links

To remove a link between two components:

  1. Left-click on the link that requires removal. It will become highlighted in blue. The link can now be edited.
  2. Click on the Remove selected objects from diagram button. A pop-up dialog box will appear, warning that a component has been selected for removal.
  3. Select either the Remove Link button or the Cancel button on the dialog box.

Alternatively, right click on the relevant link and select the Remove Link... context menu option.


Note: In addition to removing the link from the design view, the actual reference is removed from the corresponding programming element.

6.2.5 Moving components and links

Moving design elements on the Design Tool canvas is sometimes necessary to improve the layout of the design diagram.

To move a component or link on the Design Tool canvas:

  1. Ensure that Selection mode is switched on. The Selection mode button should be indented. If not, left-click on the Selection mode button to move into Selection mode.
  2. Left-click and hold the mouse button down over the element to be moved.
  3. Drag the component or link into its new position on the Design Tool canvas.

6.2.6 The floating link auto fit feature

When a design element is moved, the floating link between two components moves to a more practical position automatically. This happens in any instance where one or both of the components is moved on the Design Tool canvas in such a way that the graphical link becomes awkwardly represented, but only in cases where the link between the components is a floating rather than a fixed link.

6.2.7 Moving link-associated text

When a link is created in the Design Tool, associated text describing the type of the link is automatically generated on the Design Tool canvas. To move text about on the Design Tool canvas:

  1. Ensure that Selection mode is switched on. Selection mode is switched on when the Selection mode button is indented.
  2. Click the arrow line indicating the link with which the text is associated. The link will become highlighted in blue.
  3. The text associated with the link can now be moved to a more convenient position, using the drag-and-drop method.

6.2.8 Renaming design objects

Components and links can be renamed in the Design Tool. See the sections on editing components and links for further information.

6.3 Notes

Notes provide the facility of concise and convenient on-screen documentation.

Figure 6-1: Note icon

6.3.1 Context menus

When the Design Tool is in Selection mode, right clicking on a note opens a context menu with options for editing or removing the note.

The context menu options available for nodes are:

6.3.2 Adding a Note to a design

To add a Note to a design:

  1. Open the design palette with a single click of the left mouse button.
  2. Click the left mouse button over the Note icon within the palette.
  3. Holding the left mouse button down, drag the Note icon to the canvas. Move it into the desired position.
  4. Release the left mouse button. A dialog box will appear, providing text space for the documentation that the Note will contain.
  5. Enter the relevant documentation, and click the Apply Changes button. This will close the Note, and automatically enter the contents of the Note onto the canvas within the Note icon frame.

6.3.3 Linking a Note to a design element

Notes can be associated with design elements. This is achieved by creating a link from the Note to the element. Note that the link does not have an arrow showing an implied direction. The link between Note and design element will be illustrated within the design tool as a line between the two.

6.3.4 Editing a Note

To edit the text of a Note in a diagram, double-click with the left mouse button (or use the Edit... option of the context menu) on the relevant Note. A dialog box will open that enables the Note text to be edited.

6.3.5 Removing a Note from a design

To remove a Note from a design:

  1. Using the left mouse button, click on the Note icon. The icon will become highlighted in blue.
  2. Click on the Remove selected objects from diagram button at the top of the Design Tool. The Note will be removed.

Alternatively, when in Selection mode use the Remove from Diagram context menu option.


Note: No confirmation is required to remove a Note. When the Remove selected objects from diagram button or Remove from Diagram context menu option is selected, the Note will be removed immediately.